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I. Introduction

Welcome!    SoundBuilder is a sound editor and recording application.    

Version 1.0.1 of SoundBuilder supports the recording, playing, and editing 

of 8-bit, mono sounds.    Some of SoundBuilder’s features are listed below.    

Enjoy yourself!!

* Asynchronous recording of sound.

* Ability to specify sample rate and length of recordings.

* Asynchronous playback of sound.

* Support of cut, copy, paste, clear, and undo commands.

* Ability to play sounds in the “clipboard”.

* Save sounds as resources or in SoundBuilder’s native format.

* Save multiple sounds to one file.

* 3 to 1 and 6 to 1 compression of sounds.

* Import and export of .wav files.

This manual assumes the reader is familiar with the basic Macintosh skills 

such as opening files , clicking, dragging, manipulating windows, etc.    If 

you need help with these items, please read your Macintosh user manual 

before continuing.

A. License Information

You have the rights to use and distribute this program under the conditions 

described in sections B and C below.    If you do not agree to these terms you

must immediately destroy all copies of SoundBuilder in your possession.    
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You need not register the program, but if you do you will receive a valid 

serial number.    When the serial number is entered into the registration box,

it will stop appearing everytime you start SoundBuilder.    Serial numbers 

can be obtained by contacting the author at the address on the title sheet of

this manual or by sending E-Mail to either computer account listed on the 

title sheet.    If using US mail, please include a self-addressed, stamped 

envelope.

B. Warranty Information

This software is licensed "as is".    You use SoundBuilder entirely at your 

own risk.    The author makes no warranties or guarantees regarding the 

performance of this software and will not be held liable for damages 

resulting from the use of the software.

C. Distribution Rights

Feel free to distribute this program.    However, SoundBuilder may not be 

distributed for a profit without prior written approval from the author.    

Distribution via an electronic bulletin board is acceptable as long as there 

are no fees above normal charges.    Also, SoundBuilder must be distributed 

in the original archived format which includes the following items

* SoundBuilder 1.0.1 application

* SoundBuilder 1.0.1 Read Me file

* SoundBuilder 1.0.1 Manual (RTF)

* Welcome sound file
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You may not give your serial number to other users.

D. System Requirements

SoundBuilder will not run unless System 7.0 or greater is present.    A 

microphone is necessary to record sounds.    Make sure you activate the 

microphone via the Chooser. 

E. Technical Support

This is the first release of SoundBuilder and although I've tried to test it as 

extensively as possible, my resources are somewhat limited and there may 

still be a few bugs.    I would very much like to hear about any problems that

you encounter or if you have any ideas for new features.    I am also 

interested in hearing success stories about how you are using SoundBuilder.

Please send your comments to the author at the address found on the title 

page of this manual.    Comments can also be sent via Compuserve and 

America Online.    See the title page for the account names.    You will 

probably get the best response time via Compuserve.

II. Playing Sounds

SoundBuilder will play many different sounds.    These can be sounds that 

you have recorded yourself or sounds that were supplied by someone else.    

They can take the form of resources, SoundBuilder’s native format, or wave 

Page 5



(.wav) files from the PC world.    SoundBuilder will currently recognize only 

8-bit, mono sounds.

Before playing a sound, the sound must first be loaded into memory.    This 

can be done by recording a new sound or opening a file containing an 

existing sound.    See section III for information on recording a new sound.

To open an existing sound resource or SoundBuilder format file, choose the 

Open command in the File menu or type command-o.    All native format files

and System 7 sound resource files will be displayed by default.    If you need 

to open a file that contains sound resources but is not a standard sound 

resource file, then hold down the shift key while choosing the Open 

command.    This will cause all of the files on the disk to be displayed, 

regardless of their format.    If you choose to open a file not of 

SoundBuilder’s native format, it will be opened as a resource file.    The one 

exception to this is wave format files exported by SoundBuilder - see below 

for details.    If the file does not contain a resource fork, you will be asked if 

you would like to create one.    If the file has a resource fork, but no ‘snd ‘ 

resources, a blank window will be opened.    This is not considered an error.  

Any sounds recorded into this blank window can be saved to the file.    Note 

that SoundBuilder does not recognize “format 2” sound resources (designed

for Hypercard) as Apple’s Inside Macintosh V. 6 states that this sound 

format is now obsolete.

Any file can also be opened by dragging its icon on top of SoundBuilder’s 

icon.    This will cause SoundBuilder to start (if it is not already running) and
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open the file.    If the file is not of SoundBuilder’s native file type, it will be 

opened as a resource file.

The Import submenu under the File menu allows wave format files from 

IBM-compatible PCs to be read by SoundBuilder.    These sounds will be 

placed in an untitled window on the assumption that you will be saving the 

sound for use on other Macintoshes.    To save the sound in the wave format 

after editing, use the export command.    Wave format files exported by 

SoundBuilder will be recognized if chosen during a normal open command 

and an import will be done instead of opening the file as a resource file.

When you open a sound file, a sound editing window will be displayed with 

its title reflecting the name of the open file.    A typical sound editing window

is displayed below.    To play the loaded sound, simply click on the Play 

button.    To stop a sound that is currently playing, click on the Stop button.

The Next and Prev buttons are used to move among multiple sounds in a 

file.    To move to the next sound, click on the Next button and to move back 

to the previous sound, click on the Prev button.    If the file has no more 

sounds, the Next

button will empty the window so you can record a new sound and save it in 

the file currently open. 
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The entire sound does not have to be played at once.    Besides stopping the 

sound playback with the Stop button, a sound can also be started from any 

point.    Simply click on the graphical display of the sound in the sound 

editing window.    A small section of the display will be inverted to indicate 

the current position (i.e. where you clicked).    That is, a small section will be

displayed with white on a black background instead of black on a white 

background.    Pressing the Play button will then start the sound playing 

from the current position.      Small pieces of sound may also selected by 

using the click and drag method.    The entire section selected will be 

inverted in the sound editing window.    If there is a selected section, only 

that section will be played by the Play button.    The Rewind button 

unselects any sections and resets the current position to the beginning of 

the sound.

All sounds are loaded into Random Access Memory (RAM) in an 

uncompressed format.    Because of this, you may run short of memory when

loading large sounds.    To increase the memory available to SoundBuilder, 

follow these steps

1. Quit the SoundBuilder application.

2. Go to the Finder, and click once on the SoundBuilder icon to highlight 

it.

3. Type command-i

4. This will bring up a Get Info box.    In the box positioned in the lower 

right corner and labeled Preferred Size, type the amount of memory 

you want SoundBuilder to have available.    To see how much memory 
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is actually available choose the About This Macintosh command from 

the Apple Menu.
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III. Recording Sounds

If you have a sound input device attached to your Macintosh, you will be 

able to

record 8-bit, mono sounds with SoundBuilder.    In addition you can specify 

the length of the recording and the sampling rate used for the recording.

Set the sound’s sample rate through the Sample Rate submenu under the 

Options Menu.    The choices of rates include 5 khz, 7 khz, 11khz, 22 khz, 

and 44khz.    Some choices may not be available if your computer 

configuration doesn’t support them.    The default setting is 11khz.

To set the maximum length of your recording, choose the Length Of Sound 

command from the Options Menu.    You will be presented with the following

dialog box.

Simply enter the number of seconds you wish to record.    Once the length 

and sample rate have been set, you are ready to go.

To enter the recording mode, click on the Record button in a sound editing 

window.    If a sound is already associated with a window, it will be replaced 

by the sound you record.    Therefore, to avoid overwriting other sounds, you

should either open a new window with the New command under the File 

menu or move to the end of the current file by clicking on the Next button 
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until the window is reset with no sound displayed.    The recording mode 

dialog box is shown below.

SoundBuilder allocates RAM for the sound as soon as you enter the sound 

recording mode.    The maximum length of the sound is displayed in the 

dialog box.    The default is 5 seconds.    To begin recording, click on the 

Record button.    The Pause button will stop the recording.    Resume starts 

the recording after it has been stopped with the Pause button.    Once you 

are finished recording, click on the OK button to accept the recorded sound 

and place it in the active sound editing window.    This will replace any 

sound previously associated with that window.    To discard the sound, click 

on the Cancel button.    Any sounds associated with the window will remain 

intact.    The OK and Cancel buttons may be activated during a recording.    

They will automatically stop the recording currently in progress.    The 

recording process will also stop automatically if the maximum length is 

reached.    The amount of time recorded is represented by the progress 

indicator displayed in the middle of the dialog box.    The empty (white) part 

of the progress indicator shows the time left.    The indicator will filled to 

indicate the amount of time already recorded.

IV. Editing Sounds

A. Basic Commands
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Once a sound has been loaded into a sound editing window by either 

opening a sound file or recording a new sound, you can not only play the 

sound but also edit it in any way desired.    SoundBuilder supports the 

standard cut, copy, paste, clear, and undo commands.    All of these 

commands can be found under the Edit menu.

Before you can use the cut, copy, or clear commands, a section of the sound 

must be selected.    To do this, click on the sound’s graphical representation 

in the sound editing window and drag the cursor over the section to be 

selected.    This section of sound will then be inverted to indicate it is 

selected.    The Select All command under the Edit menu will select the 

entire sound.

The Cut command will remove the selection from the sound and store it in 

SoundBuilder’s clipboard.    SoundBuilder currently maintains its own 

storage area for this data.    It is not available to other applications.    The 

Copy command will store a copy of the current selection in    SoundBuilder’s

clipboard.    The Clear command will remove the current selection from the 

sound, but it does not affect the clipboard in any way.

After a selection has been cut or copied, it can be put back into the sound 

(or any other sound currently open) by clicking on the desired insertion 

point and choosing the Paste command.    Selections can also be pasted into 

empty windows.

The Undo command will reverse the actions taken by the last editing 

command.    The Undo command is the only way to retrieve a selection that 
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has been cleared.    If an entire sequence of commands needs to be 

“undone”, the only way to do this is through the Revert command under the 

File menu.    This command will discard the current sound and read in the 

last version of the sound written to disk.    If the changes have already been 

saved to a file, there is no way to undo any change except the last one 

made.    This is also true if the sound has never been saved.

To hear the selection currently in the clipboard, first activate the clipboard 

window with the Show Clipboard command under the Edit menu.    This will 

display a window with a graphical representation of the clipboard’s 

contents.    To play the contents of the clipboard,    hold the option key down 

while clicking in the clipboard window.    To hide the clipboard window, 

choose the Show Clipboard command a second time.    This command will be

checked if the window is opened and unchecked if the clipboard window is 

closed.
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B. Close-up Editing

The View menu offers two options for more detailed editing of sounds.    

Once a section of sound is selected, the Zoom menu option will cause only 

that selection to be displayed in the sound editing window.    The UnZoom 

command will restore the sound editing window to its default state (i.e. the 

entire sound will be displayed).    These commands should give the user the 

ability to do more detailed editing.

C. Markers

When editing a sound it may be desirable to place a marker on a certain 

location such as the beginning of a word.    SoundOff allows you to do this by

holding the option key down while clicking in the sound editing window.    

An upside down triangle is drawn just above the sound’s graphical display 

to indicate a marker has been inserted at that point.    The location of 

markers is also saved in SoundBuilder’s native file format.    Markers will be 

lost if you save the sound as a resource or if you export the sound to some 

other format.

Information about the marker can be viewed by choosing the Marker Info 

command under the Options menu.    The following dialog box will be 

displayed.
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The dialog shows a list of currently defined markers.    The size of the sound 

and the beginning and end positions of the sound section currently 

displayed in the sound editing window are also given as well as the position 

of the marker currently selected in the list.    To remove the highlighted 

marker, click on the Remove button.    As in other dialog boxes, the OK 

button tells SoundBuilder to keep the changes that have been made and the

Cancel button will cause all changes to be discarded.    When removing 

markers, you will not be given a warning.    The only way to restore deleted 

markers is to cancel all of the changes that have been made.

By default markers are named according to their position in the sound.    For

example, the dialog box above displays a marker located at byte 1329 of the

sound.    The marker’s name is also 1329.    To change the name of a marker, 

highlight it in the list by clicking on its current name and then click on the 

Name button.    The dialog below will then allow a new name to be specified.

Simply type in the new name and click on the OK button to implement the 

change.    Click on the Cancel button to discard any typing and keep the 

previous name.

V. Saving Sounds

Three file formats are supported by SoundBuilder.    Sounds can be saved as 

Macintosh sound resource files, as SoundBuilder files, or as wave files.    File

formats are generally indicated by the Save Sound As box in the sound 

Page 15



editing window.    This box is set to the proper format when a file is opened.   

New and imported sounds default to a Resource file type.    It should be 

noted, however, that the user may change these buttons at any time.    This 

change is ignored by the Save command.    Only the Save As command uses 

the buttons to determine the proper file format.    The format of files opened 

using the Open command will be preserved unless changed to a different 

format and saved with the Save As command.
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A. Compression

Sounds saved as resources or SoundBuilder files can also be compressed.    

To save a file in a compressed format, choose the desired compression 

method from the Compression sub-menu under the Options menu.    Do this 

before using the Save or Save As commands.    Sound sizes will be reduced 

to 1/3 of the normal size by the 3 to 1 method and to 1/6 of the normal size 

by the 6 to 1 method.    Compression may result in a loss of sound quality.

B. Resources

To save a sound as a System 7 Sound Resource, click on the Resource radio 

button in the sound editing window and then choose the Save As command 

under the File menu.    Files saved in this format can be played from the 

Finder by double-clicking on the file’s icon.    SoundBuilder can also save 

sound resources to files that are not Finder-playable, but this can only be 

done if sound resources already exist in the file.    For example, if the file 

“My Sounds” contains sound resources, then SoundBuilder can open the 

file, read in and edit the sound resources, and add additional resources.    

However, if you try to open a file that does not contain sound resources, 

SoundBuilder will tell you it cannot read past the end of the file and will not 

open the file.    New resource files created by SoundBuilder will always be 

Finder-playable.    It should be noted that the Finder will play only one of the

resources in the file, not all of them.

C. SoundBuilder File Format
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To save a file in SoundBuilder’s native format, choose the File button in the 

sound editing window and then use the Save As command.    SoundBuilder 

records the necessary information to continue editing the sound at a later 

time, including any markers that were defined.    The format is defined 

below.

Information                                Data Type               Bytes  

Major version number Integer 2

Minor version number Integer 2

Repeated for    each sound

Size of sound Integer 4

Sample rate Fixed 4

Compression Type String 4

Number of markers Integer 2

Repeated for each marker

Marker position Integer 4

Length of marker nameInteger 1

Marker name String ?

Sound sample data ---- ?

D. Wave Files

The Export submenu under the File menu allows sounds to be saved in the 

wave file format for use with Microsoft’s Windows 3.1 and any other 

program which recognizes the wave format.    These files are specifically 

designed for use with the IBM-compatible world of computers.
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VI. Menu Commands

A. File Menu

New Create an empty sound editing window.    See pages 10, 15 and 

16.

Open Open an existing sound file.    See pages 6, 15, and 16.

Import Read non-standard sound files.    See pages 6 and 15.

Close Close the active sound editing window and associated files.

Save Save the sound associated with the active sound editing window

in the file associated with the sound editing window.    Same as 

“Save As” if the sound was not previously saved.    See pages 12,

13, and 15-17.

Save As Save the sound associated with the active sound editing window

under a new file name.    See pages 12, 13, and 15-17.

Revert Discard the active sound and read the last version of the sound 

saved to disk.    See page 12.

Export Save sounds in non-standard formats.    See pages 6, 13, and 17.

Quit Close the SoundBuilder application.    The user is given the 

opportunity to save any edited sounds.

B. Edit Menu

Undo Reverse the last editing command.    See pages 11 and 12.

Cut Remove the current selection from the sound and place it in 

SoundBuilder’s clipboard.    See pages 11 and 12.

Copy Copy the current selection to the clipboard.    See pages 11-12.
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Paste Paste the contents of the clipboard into the active sound at the 

current position.    See pages 11-12.

Clear Remove the current selection from the sound.    See pages 11-12.

Select All Select the entire active sound.    See page 11.

Show Clipboard Display or hide the clipboard.    See page 12.

C. View Menu

Zoom Zoom in on the selected sound.    See page 13.

UnZoom Display the entire sound in the editing window.    See page 13.

D. Options Menu

Compression Choose a compression method.    See pages 8, 16, and 17.

Sample Rate Choose the sample rate for the next sound recording.    

See pages 9 and 17.

Marker Info View information about defined markers.    See pages 13-

15 and 17.

Length of Sound Set the maximum length to record.    See pages 9-11.

E. Windows Menu

This menu will display the names of the open windows.    Choose one to 

make it the active window.
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